手机端
当前位置:主页 > 配资平台 > 配资网站 >

通达信公式指标源码:量价抵值主图

通达信公式指标源码:量价抵值主图 DRAWTEXT(CURRBARSCOUNT=5,HIGH*1.01,'5日'); {DRAWLINE(扣抵5,C,C,MA(C,5),0),COLORWHITE,LINETHICK2;} DRAWTEXT(CURRBARSCOUNT=10,HIGH*1.01,'10日'); {DRAWLINE(扣抵10,C,C, MA

通达信公式指标源码:量价抵值主图

复星医药600196股票最新价格

DRAWTEXT(CURRBARSCOUNT=5,HIGH*1.01,'5日');

{DRAWLINE(扣抵5,C,C,MA(C,5),0),COLORWHITE,LINETHICK2;}

DRAWTEXT(CURRBARSCOUNT=10,HIGH*1.01,'10日');

{DRAWLINE(扣抵10,C,C, MA(C,10),0),COLORYELLOW,LINETHICK2;}

DRAWTEXT(CURRBARSCOUNT=20,HIGH*1.01,'20日');

{DRAWLINE(扣抵20,C,C, MA(C,20),0),COLORMAGENTA,LINETHICK2;}

DRAWTEXT(CURRBARSCOUNT=60,HIGH*1.01,'60日');

{DRAWLINE(扣抵60,C,C, MA(C,60),0),COLORRED,LINETHICK2;}

DRAWTEXT(CURRBARSCOUNT=120,HIGH*1.01,'120日');

{DRAWLINE(扣抵120,C,C, MA(C,120),0),COLORGRAY,LINETHICK2;}

DRAWTEXT(CURRBARSCOUNT=250,HIGH*1.01,'250日');

{DRAWLINE(扣抵250,C,C, MA(C,250),0),COLORBLUE,LINETHICK2;}

{DRAWICON(CURRBARSCOUNT=5,HIGH,14);

DRAWICON(CURRBARSCOUNT=10,HIGH,14);

DRAWICON(CURRBARSCOUNT=20,HIGH,14);

DRAWICON(CURRBARSCOUNT=60,HIGH,14);

DRAWICON(CURRBARSCOUNT=120,HIGH,14);

DRAWICON(CURRBARSCOUNT=250,HIGH,14);}

MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA60:MA(CLOSE,60);

MA120:MA(CLOSE,120);

MA250:MA(CLOSE,250);

DRAWRECTREL(0,0,240,350,RGB(0,0,1));

DRAWTEXT_FIX(C>0,0.04 ,0.07,1,'当前情况:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.04 ,0.11,1,'005日扣抵:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.04 ,0.15,1,'010日扣抵:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.04 ,0.19,1,'020日扣抵:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.04 ,0.23,1,'060日扣抵:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.04 ,0.27,1,'120日扣抵:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.005 ,0.090,0,'----------------------------------------------------------------------------------------'),COLORGRAY;

DRAWTEXT_FIX(C>0,0.065 ,0.03,1,'价(元)'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>0,0.065 ,0.07,1,VAR2STR(C,2)),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,4),0.065 ,0.11,1,VAR2STR(REF(C,4),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,4),0.065 ,0.11,1,VAR2STR(REF(C,4),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,4),0.065 ,0.11,1,VAR2STR(REF(C,4),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,9),0.065 ,0.15,1,VAR2STR(REF(C,9),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,9),0.065 ,0.15,1,VAR2STR(REF(C,9),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,9),0.065 ,0.15,1,VAR2STR(REF(C,9),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,19),0.065 ,0.19,1,VAR2STR(REF(C,19),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,19),0.065 ,0.19,1,VAR2STR(REF(C,19),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,19),0.065 ,0.19,1,VAR2STR(REF(C,19),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,59),0.065 ,0.23,1,VAR2STR(REF(C,59),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,59),0.065 ,0.23,1,VAR2STR(REF(C,59),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,59),0.065 ,0.23,1,VAR2STR(REF(C,59),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,119),0.065 ,0.27,1,VAR2STR(REF(C,119),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,119),0.065 ,0.27,1,VAR2STR(REF(C,119),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,119),0.065 ,0.27,1,VAR2STR(REF(C,119),2)),COLORGREEN;

VART1:=ABS((C-REF(C,4)))*100/C,NODRAW;

VART1_1:=IF(VART1>999,999.9,VART1),NODRAW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,4),0.09 ,0.11,1,STRCAT(VAR2STR(VART1_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,4),0.09 ,0.11,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,4),0.09 ,0.11,1,STRCAT(VAR2STR(VART1_1,1),'%')),COLORGREEN;

VART2:=ABS((C-REF(C,9)))*100/C,NODRAW;

VART2_1:=IF(VART2>999,999.9,VART2),NODRAW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,9),0.09 ,0.15,1,STRCAT(VAR2STR(VART2_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,9),0.09 ,0.15,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,9),0.09 ,0.15,1,STRCAT(VAR2STR(VART2_1,1),'%')),COLORGREEN;

VART3:=ABS((C-REF(C,19)))*100/C,NODRAW;

VART3_1:=IF(VART3>999,999.9,VART3),NODRAW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,19),0.09 ,0.19,1,STRCAT(VAR2STR(VART3_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,19),0.09 ,0.19,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,19),0.09 ,0.19,1,STRCAT(VAR2STR(VART3_1,1),'%')),COLORGREEN;

VART4:=ABS((C-REF(C,59)))*100/C,NODRAW;

VART4_1:=IF(VART4>999,999.9,VART4),NODRAW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,59),0.09 ,0.23,1,STRCAT(VAR2STR(VART4_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,59),0.09 ,0.23,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,59),0.09 ,0.23,1,STRCAT(VAR2STR(VART4_1,1),'%')),COLORGREEN;

VART5:=ABS((C-REF(C,119)))*100/C,NODRAW;

VART5_1:=IF(VART5>999,999.9,VART5),NODRAW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,119),0.09 ,0.27,1,STRCAT(VAR2STR(VART5_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C=REF(C,119),0.09 ,0.27,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,119),0.09 ,0.27,1,STRCAT(VAR2STR(VART5_1,1),'%')),COLORGREEN;

DRAWTEXT_FIX(C>0,0.12 ,0.03,1,'量(万)'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>0,0.12 ,0.07,1,VAR2STR(V/10000,2)),COLORYELLOW;

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1))))),NODRAW;

MTIME:=MOD(FROMOPEN,TOTAL),NODRAW;

CTIME:=IF(MTIME<0.5,TOTAL,MTIME),NODRAW;

VVOL:=IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*(TOTAL+3)/(CTIME+3),0),NODRAW;

DRAWTEXT_FIX(C>0,0.18 ,0.03,1,'虚拟量(万)'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND VVOL>0,0.18 ,0.07,1,VAR2STR(VVOL/10000,2)),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,4),0.12 ,0.11,1,VAR2STR(REF(V/10000,4),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,4),0.12 ,0.11,1,VAR2STR(REF(V/10000,4),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,4),0.12 ,0.11,1,VAR2STR(REF(V/10000,4),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,9),0.12 ,0.15,1,VAR2STR(REF(V/10000,9),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,9),0.12 ,0.15,1,VAR2STR(REF(V/10000,9),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,9),0.12 ,0.15,1,VAR2STR(REF(V/10000,9),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,19),0.12 ,0.19,1,VAR2STR(REF(V/10000,19),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,19),0.12 ,0.19,1,VAR2STR(REF(V/10000,19),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,19),0.12 ,0.19,1,VAR2STR(REF(V/10000,19),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,59),0.12 ,0.23,1,VAR2STR(REF(V/10000,59),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,59),0.12 ,0.23,1,VAR2STR(REF(V/10000,59),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,59),0.12 ,0.23,1,VAR2STR(REF(V/10000,59),2)),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,119),0.12 ,0.27,1,VAR2STR(REF(V/10000,119),2)),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,119),0.12 ,0.27,1,VAR2STR(REF(V/10000,119),2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,119),0.12 ,0.27,1,VAR2STR(REF(V/10000,119),2)),COLORGREEN;

VART21:=ABS((V-REF(V,4)))*100/V;

VART21_1:=IF(VART21>999,999.9,VART21),NODRAW;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,4),0.155 ,0.11,1,STRCAT(VAR2STR(VART21_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,4),0.155 ,0.11,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,4),0.155 ,0.11,1,STRCAT(VAR2STR(VART21_1,1),'%')),COLORGREEN;

VART22:=ABS((V-REF(V,9)))*100/V;

VART22_1:=IF(VART22>999,999.9,VART22);

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,9),0.155 ,0.15,1,STRCAT(VAR2STR(VART22_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,9),0.155 ,0.15,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,9),0.155 ,0.15,1,STRCAT(VAR2STR(VART22_1,1),'%')),COLORGREEN;

VART23:=ABS((V-REF(V,19)))*100/V;

VART23_1:=IF(VART23>999,999.9,VART23);

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,19),0.155 ,0.19,1,STRCAT(VAR2STR(VART23_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,19),0.155 ,0.19,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,19),0.155 ,0.19,1,STRCAT(VAR2STR(VART23_1,1),'%')),COLORGREEN;

VART24:=ABS((C-REF(C,59)))*100/C;

VART24_1:=IF(VART24>999,999.9,VART24);

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,59),0.155 ,0.23,1,STRCAT(VAR2STR(VART24_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,59),0.155 ,0.23,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,59),0.155 ,0.23,1,STRCAT(VAR2STR(VART24_1,1),'%')),COLORGREEN;

VART25:=ABS((C-REF(C,119)))*100/C;

VART25_1:=IF(VART25>999,999.9,VART25);

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V>REF(V,119),0.155 ,0.27,1,STRCAT(VAR2STR(VART25_1,1),'%')),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V=REF(V,119),0.155 ,0.27,1,VAR2STR(0,2)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V<REF(V,119),0.155 ,0.27,1,STRCAT(VAR2STR(VART25_1,1),'%')),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,4) AND VVOL>REF(V,4),0.16 ,0.11,0,'5日均线助涨'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,4) AND VVOL<REF(V,4),0.16 ,0.11,0,'5日均线领跌'),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,9) AND VVOL>REF(V,9),0.16 ,0.15,0,'10日均线助涨'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,9) AND VVOL<REF(V,9),0.16 ,0.15,0,'10日均线领跌'),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,19) AND VVOL>REF(V,19),0.16 ,0.19,0,'20日均线助涨'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,19) AND VVOL<REF(V,19),0.16 ,0.19,0,'20日均线领跌'),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,59) AND VVOL>REF(V,59),0.16 ,0.23,0,'60日均线助涨'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,59) AND VVOL<REF(V,59),0.16 ,0.23,0,'60日均线领跌'),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,119) AND VVOL>REF(V,119),0.16 ,0.27,0,'120日均线助涨'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,119) AND VVOL<REF(V,119),0.16 ,0.27,0,'120日均线领跌'),COLORGREEN;

分享至:

相关阅读